Como encontrar valores duplicados sem removê-los do Excel?

Opa! Bem vindo(a) a mais uma aula! Hoje você vai aprender como encontrar valores duplicados sem removê-los do Excel.

Acredito que você já tenha passado por uma situação em que precisasse remover nomes, valores, códigos duplicados no Excel e como não conhecia a forma que vou te ensinar agora, teve que fazer um a um, perdendo um grande tempo.

Existe a ferramenta Remover Duplicadas (dependendo da versão do seu Excel, vai estar escrito Remover Duplicatas) do próprio Excel, porém, não queremos excluir os valores duplicados, queremos que apenas nos mostre quem são esses valores duplicados.

Encontre Valores Duplicados por Formatação Condicional

Formatação Condicional pode destacar rapidamente os valores duplicados em uma lista. E para isso siga os seguintes passos:

1 – Selecione o intervalo que você deseja encontrar os valores duplicados. No exemplo abaixo selecionei de A2 até A12.

2 – Agora vá em Página Inicial, Formatação Condicional, Regras de Realce das Células, Valores Duplicados.

3 – Será aberta a janela Valores Duplicados, onde você poderá escolher destacar os duplicados ou exclusivos e ainda personalizar um tipo de cor de sua preferência.

Simples e muito fácil não é mesmo?

Agora vamos aprender outra forma de encontrar valores duplicados sem excluí-los?

Encontre Valores Duplicados sem excluí-los através de fórmulas

Vamos agora usar uma fórmula para identificar valores duplicados sem precisar excluir.

Para isso precisamos juntar duas funções: SE e CONT.SE

Usando o mesmo exemplo anterior copie a fórmula abaixo para sua planilha.

=SE(CONT.SE($A$2:$A$12;A2)>1;”Duplicado”;””)

O que esta fórmula faz? Ela usa o CONT.SE para contar quantas vezes cada palavra se repetiu e através da função SE, inserimos uma condicional, dizendo que se a contagem do CONT.SE for maior que 1, escreva “Duplicado”, caso contrário não escreva nada.

Podemos também identificar somente os valores duplicados que aparecem na segunda, terceira, quarta… vez. Ou seja, excluímos as primeiras aparições. Como a fórmula abaixo:

=SE(CONT.SE(A$2:A2;A2)>1;”Duplicado”;””)

E aí? Gostou das dicas?

Se você também souber outras formas de identificar valores duplicados em planilhas, por favor, nos mostre através dos comentários abaixo. Vamos adorar isso!

Forte abraço e até a próxima!

Tags: | | | | | | | | | | |

Quer mais dicas como esta?

Cadastre-se agora e receba tudo de primeira!

Não enviamos spam. Seu e-mail está 100% seguro!

Sobre o Autor

0 Comentários

Deixe um comentário

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *

Este site utiliza Cookies e Tecnologias semelhantes para melhorar a sua experiência. Ao utilizar nosso site você concorda que está de acordo com a nossa Política de Privacidade.