Olá! Muitas vezes você já deve ter passado pela seguinte situação: recebeu uma base de dados com CNPJs e muitos estão desconfigurados, ou seja, não contemplam os 14 dígitos. Pois, neste artigo você aprenderá como adicionar zeros à esquerda de um número.

Números faltando zeros à esquerda

Em primeiro lugar, imagine que você recebeu a seguinte base de dados com CNPJs desconfigurados, faltando alguns números para completar os 14 dígitos desse código.

E portanto, neste caso precisamos inserir os zeros à esquerda de cada número. Aqueles que já possuem os 14 dígitos ficarão do jeito que está.

CNPJs faltando os zeros à esquerda

É possível você completar esses números manualmente, mas, dependendo da quantidade dessa lista de CNPJs vai demorar uma eternidade.

Então para isso vamos aprender duas formas de adicionar ou acrescentar zeros à esquerda desses números.

Acrescentar zeros à esquerda utilizando a função TEXTO

A princípio uma das formas para adicionar zeros à esquerda de um número é utilizar a função TEXTO do Excel. Que possui em sua estrutura os seguintes argumentos:

=TEXTO(valor;formato_texto)

  • TEXTO: é a função propriamente dita
  • valor: pode ser uma número, texto, fórmula que sofrerá a alteração conforme a necessidade
  • formato_texto: é o formato que queremos chegar com a alteração do valor

Em uma célula digite a seguinte fórmula:

=TEXTO(A2;”00000000000000″)

Onde A2 é o número que queremos alterar e os 14 zeros são o número de dígitos que queremos que nossos CNPJs fiquem.

Função TEXTO para formatar número

Por fim, pressione ENTER do seu teclado e pronto! Veja que foram acrescentados a quantidade de zeros de tal forma que completamos os 14 dígitos de cada número. Exemplo, se temos apenas um dígito, vão ser acrescentados 13 zeros.

zeros à esquerda

Muito simples não é mesmo?

Há também uma outra forma. Muito parecida com a primeira, porém, nesta acrescentaremos mais uma função: REPT.

Em outras palavras, vamos melhorar um pouco mais nosso exemplo.

Acrescentar zeros à esquerda utilizando as funções TEXTO e REPT

Para acrescentar mais uma função na nossa fórmula, escreveremos da seguinte forma:

=TEXTO(A2;REPT(0;14))

A função REPT, possui dois argumentos: texto e número_vezes. Sua estrutura é assim:

=REPT(texto;número_vezes)

  • texto: o texto que queremos repetir
  • número_vezes: a quantidade de vezes que queremos que o texto se repita

Portanto, ao invés de inserir os zeros 14 vezes, apenas digitaremos uma vez o número zero e a quantidade de vezes que queremos que ele se repita. Mais simples ainda né?

Por fim, esta são duas formas de acrescentar zeros à esquerda de um número utilizando funções ou fórmulas.

E você conhece algum jeito de se fazer isso?

Compartilhe seu conhecimento aí embaixo! Vamos adorar aprender com você!

Até a próxima!

Tags: | | | | | | | |

Precisa de Aulas de Excel?

Aulas de Excel, trabalhos e planilhas personalizadas!

Fale Comigo Agora* Basta clicar no botão acima

Sobre o Autor

0 Comentários

Deixe um comentário

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *

Solicitar exportação de dados

Utilize este formulário para solicitar uma cópia dos seus dados neste site.

Solicitar remoção de dados

Utilize este formulário para solicitar a remoção dos seus dados neste site.

Solicitar retificação de dados

Utilize este formulário para solicitar a retificação dos seus dados neste site. Aqui você pode corrigir ou atualizar seus dados por exemplo.

Solicitar cancelamento de inscrição

Utilize este formulário para solicitar o cancelamento de inscrição do seu e-mail em nossas Listas de E-mail.