Olá! Seja muito bem vindo(a) a mais uma dica de Excel. Neste artigo vamos tentar responder a seguinte pergunta: PROCV ou PROCX: Qual função usar no Excel?

Primeiramente sabemos que o Excel é uma ferramenta poderosa para trabalhar com dados e realizar cálculos. E uma das funções mais usadas no Excel é a PROCV, que permite buscar um valor em uma tabela verticalmente e retornar um resultado de outra coluna.

Por exemplo, você pode usar a PROCV para encontrar o nome de um cliente pelo seu código ou o preço de um produto pelo seu código de barras.

No entanto, a PROCV tem algumas limitações e desvantagens que podem dificultar o seu uso em alguns casos.

Por exemplo, ela só funciona da esquerda para a direita, ou seja, a coluna de busca tem que estar à esquerda da coluna de retorno.

Além disso, PROCV pode retornar resultados incorretos se a tabela não estiver ordenada ou se houver valores duplicados na coluna de busca.

Para resolver esses problemas, o Excel lançou uma nova função chamada PROCX, que é uma evolução da PROCV e oferece mais flexibilidade e facilidade nas buscas.

A PROCX permite buscar um valor em uma matriz (que pode ser vertical ou horizontal) e retornar um resultado de outra matriz (que pode estar em qualquer posição).

Além disso, a PROCX tem mais opções de correspondência e de pesquisa, que permitem controlar melhor os resultados.

Como usar a PROCX no Excel?

A sintaxe da PROCX no Excel é a seguinte:

=PROCX (pesquisa_valor; pesquisa_matriz; matriz_retorno; [se_não_encontrada]; [modo_correspondência]; [modo_pesquisa])

Os argumentos são:

  • pesquisa_valor: o valor que você quer buscar na matriz.
  • pesquisa_matriz: a matriz ou intervalo onde está o valor que você quer buscar.
  • matriz_retorno: a matriz ou intervalo de onde você quer retornar o resultado.
  • se_não_encontrada: o que você quer que a função retorne se não encontrar uma correspondência válida. Se omitido, retorna #N/D.
  • modo_correspondência: o tipo de correspondência que você quer usar na busca. Pode ser 0 (correspondência exata), -1 (correspondência exata ou menor), 1 (correspondência exata ou maior) ou 2 (correspondência com curingas). Se omitido, usa 0 por padrão.
  • modo_pesquisa: o modo de pesquisa que você quer usar na busca. Pode ser 1 (pesquisa do primeiro para o último item), -1 (pesquisa do último para o primeiro item), 2 (pesquisa binária em ordem crescente) ou -2 (pesquisa binária em ordem decrescente). Se omitido, usa 1 por padrão.

Exemplo de PROCX no Excel

Vamos ver um exemplo prático de como usar a PROCX no Excel. Suponha que você tenha a seguinte tabela com dados de produtos:

CódigoNomePreçoCategoria
A001LápisR$ 1,00Material escolar
A002BorrachaR$ 0,50Material escolar
A003CanetaR$ 2,00Material escolar
B001CadernoR$ 10,00Material escolar
B002LivroR$ 20,00Livraria
B003RevistaR$ 5,00Livraria
C001MouseR$ 50,00Informática
C002TecladoR$ 80,00Informática
C003MonitorR$ 500,00Informática

Copie e cole esta tabela em sua planilha a partir da célula A1.

Agora imagine que você quer buscar o nome e a categoria de um produto pelo seu código. Você poderia usar a PROCV para isso, mas teria que repetir a função duas vezes e mudar o número do índice da coluna. Por exemplo:

=PROCV(“B002”;A2:D10;2;FALSO) para buscar o nome do produto.

=PROCV(“B002”;A2:D10;4;FALSO) para buscar a categoria do produto.

Com a PROCX, você pode fazer isso com uma única função e sem se preocupar com a posição das colunas. Por exemplo:

=PROCX(“B002”;A2:A9;B2:B10) para buscar o nome do produto.

=PROCX(“B002”;A2:A9;D2:D10) para buscar a categoria do produto.

Veja que a PROCX permite que você use qualquer coluna como matriz de retorno, desde que esteja no mesmo intervalo da matriz de busca.

Além disso, você não precisa usar o argumento se_não_encontrada, pois a PROCX retorna #N/D por padrão se não encontrar uma correspondência exata.

Vantagens da PROCX em relação à PROCV

A PROCX tem algumas vantagens em relação à PROCV que podem facilitar o seu trabalho no Excel. Veja algumas delas:

A PROCX é mais geral e pode fazer buscas tanto na vertical quanto na horizontal.

Isso significa que você pode usar a mesma função para buscar valores em linhas ou em colunas, sem precisar usar a PROCH (que é a versão horizontal da PROCV).

É mais flexível e permite que você escolha o tipo de correspondência e o modo de pesquisa que quiser.

Isso significa que você pode usar a PROCX para buscar valores exatos, aproximados ou com curingas (* e ?), e também pode definir se quer pesquisar do primeiro para o último item, do último para o primeiro item ou usando uma pesquisa binária (que é mais rápida e precisa, mas requer que a matriz esteja ordenada).

É mais dinâmica e se adapta às mudanças na tabela. Isso significa que você não precisa se preocupar em atualizar os números dos índices das colunas ou em ordenar a tabela toda vez que inserir ou excluir dados.

A PROCX usa matrizes como argumentos e se ajusta automaticamente às alterações na estrutura da tabela.

Aqui está uma tabela comparativa entre as funções PROCX e PROCV, destacando suas principais diferenças:

PROCXPROCV
Sintaxe=PROCX(pesquisa_valor; pesquisa_matriz; matriz_retorno; [se_não_encontrada]; [modo_correspondência]; [modo_pesquisa])=PROCV(pesquisa_valor; pesquisa_matriz; número_coluna; [intervalo_pesquisa])
Procura em colunasNãoSim
Procura em linhasSimSim
Valor padrão se não encontrado#N/D#N/D
Correspondência exataOpcionalOpcional
Correspondência aproximadaOpcionalOpcional
Requer ordenação préviaNãoSim
Possui mais de um critério de pesquisaNãoNão
Permite pesquisa em múltiplas colunasNãoSim
Flexibilidade de comparaçãoComparação exataComparação exata ou aproximada

Conclusão

A PROCX é uma função nova e melhorada do Excel que veio para substituir a PROCV em muitos casos.

Ela permite que você faça buscas mais rápidas, fáceis e precisas em tabelas ou matrizes, sem as limitações e desvantagens da PROCV.

E aí? Você consegue responder a pergunta? “PROCV ou PROCX: Qual função usar no Excel?”

Comente aí embaixo.

Tags: | | | |

Precisa de Aulas de Excel?

Aulas de Excel, trabalhos e planilhas personalizadas!

Fale Comigo Agora* Basta clicar no botão acima

Sobre o Autor

0 Comentários

Deixe um comentário

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *

Solicitar exportação de dados

Utilize este formulário para solicitar uma cópia dos seus dados neste site.

Solicitar remoção de dados

Utilize este formulário para solicitar a remoção dos seus dados neste site.

Solicitar retificação de dados

Utilize este formulário para solicitar a retificação dos seus dados neste site. Aqui você pode corrigir ou atualizar seus dados por exemplo.

Solicitar cancelamento de inscrição

Utilize este formulário para solicitar o cancelamento de inscrição do seu e-mail em nossas Listas de E-mail.