Como classificar texto em ordem alfabética no Excel

Avançado

Como classificar texto em ordem alfabética no Excel

Geraldo
Escrito por Geraldo

Opa! Geraldo novamente aqui! Hoje vamos aprender mais uma dica bem legal e que é pouco divulgada. Vamos aprender como classificar texto em ordem alfabética no Excel utilizando uma fórmula.

Sabemos que existe a função ORDEM.EQ do Excel, porém, ela funciona somente com números. Mas, e no caso dos textos, como fazemos?

Fácil! Basta utilizar a função CONT.SE!

Como classificar

Abra um arquivo Excel e digite os seguintes nomes, começando pela célula A1.

NOMERANKING
GERALDO
BIANCA
JULIANA
VANESSA
PEDRO
JOÃO
AMANDA
LUCIANA A.
LUCIANA B.

Agora digite na célula B2 a seguinte fórmula:

=CONT.SE($A$2:$A$10;”<=”&A2)

Replique a fórmula para as outras células e veja o resultado. Teremos a numeração de acordo com a ordem alfabética dos nomes, onde AMANDA é o primeiro nome e VANESSA o último.

Também podemos observar que os nomes LUCIANA A. e LUCIANA B. estão corretamente classificados.

E para finalizar formate os números de acordo com a necessidade para ficar algo mais apresentável.

Gostou da dica? E aí? Você tem outra forma de classificar por ordem alfabética? Compartilhe conosco.

Um fortíssimo abraço e até a próxima!

Geraldo – Excel 24 Horas

Olá,

o que você achou deste conteúdo? Conte nos comentários.

Deixe uma resposta