Buscar valores usando o PROCV

Intermediário

Buscar valores usando o PROCV

Geraldo
Escrito por Geraldo em 30 de agosto de 2019

Opa! Neste artigo vamos entender como buscar valores usando o PROCV. Vimos isso utilizando o ÍNDICE + CORRESP em outra postagem e agora saberemos de forma simples como usar o PROCV.

Mas, afinal o que é o PROCV?

O próprio nome já diz! PROC – Procurar e V – Vertical, ou seja, procurar na vertical.

O que esta função faz é simplesmente a busca de um determinado valor na vertical de cima para baixo em um intervalo. Esse valor pode ser um texto, um número ou uma célula nomeada.

Estrutura do PROCV

O PROCV é formado por quatro argumentos. São eles:

  • Valor_procurado: é o valor da primeira coluna a ser localizado em uma matriz ou intervalo.
  • Matriz_tabela: é o intervalo que servirá como base para buscar o Valor_procurado.
  • Núm_índice_coluna: é o número da coluna da Matriz_tabela, onde será procurado o valor.
  • Procurar_intervalo: é um valor lógico informando se o retorno do Valor_procurado será exato (FALSO ou 0) ou aproximado (VERDADEIRO ou 1)
=PROCV(Valor_procurado;Matriz_tabela;Núm_índice_coluna;Procurar_intervalo)

Agora vamos praticar um pouco para entendermos melhor como buscar valores usando o PROCV.

Exemplo prático

À partir da célula B2 crie uma pequena tabela como na Figura 1: Vendedor, Meta e Valor.

Em primeiro lugar, queremos encontrar qual é o valor da meta e o valor da venda de um vendedor específico. O vendedor C por exemplo.

Figura 1

À partir da célula G2 faça como na Figura 2. Será aqui que faremos as buscas dos valores.

Figura 2

Na célula H3 digite a função da seguinte forma:

=PROCV(G3;B2:D7;2;0)

Onde:

  • G3 é o Valor_procurado (aqui iremos digitar um vendedor)
  • B2:D7 é o intervalo ou matriz, onde faremos a busca
  • 2 é o número da coluna onde se encontra a meta (contamos a partir da primeira coluna do intervalo)
  • 0 é o valor exato da meta que queremos encontrar

E para finalizar, vamos colocar algumas células como referências absolutas para podermos arrastar a mesma fórmula para a coluna do valor.

Primeiro vamos fixar a célula G3, pois, será sempre nela o Valor_procurado. Ficando assim: $G$3.

Agora vamos fixar o intervalo B2:D7, para que o PROCV procure somente neste intervalo, independentemente se arrastarmos a fórmula. Desta forma $B$2:$D$7.

=PROCV($G$3;$B$2:$D$7;2;0)

Quando terminar a função conforme acima e der ENTER, será retornado o resultado #N/D.

Este é um erro muito comum que ocorre no PROCV, que significa NÃO DEFINIDO ou não encontrado.

Para trazer o valor que procura digite qualquer letra dos vendedores. No exemplo abaixo, digitei C e foi retornado a meta de 2.200,00, conforme a tabela matriz.

Faça o teste também com os outros vendedores. Digite A, B, D…

Muito simples não é mesmo?

Finalizando

Finalmente arraste a fórmula para a coluna do Valor e como havíamos fixado como referência absoluta nos passos anteriores, você vai notar que o mesmo valor da meta 2.200,00 se repetiu. Mas, calma que isso é resolvido alterando o número da coluna de 2 para 3, pois, afinal pulamos mais uma coluna para a direita que é a I onde teremos o valor de 2.800,00.

Agora altere para outros vendedores e verá que os valores são atualizados automaticamente. Muito legal não é mesmo?

Portanto, pratique bastante o PROCV de outras formas. Aqui mostrei para você o básico. Há inúmeras possibilidades de combiná-lo com outras funções. E isso te mostrarei em outras postagens. Por enquanto ficamos por aqui e eu te deixo o meu fortíssimo abraço!

Geraldo – Excel 24 Horas

Olá,

o que você achou deste conteúdo? Conte nos comentários.